Club Touareg Forum banner

VW Touareg RNS850 Australia Region Maps Update - version 5.13.4 latest one... 2021

8965 Views 213 Replies 24 Participants Last post by  Weekev
Here's the newest available map update for the RNS850 Australia Region:

1. You can't find this archive anywhere in the internet, cause it's made by myself. It's a simple Audi MMI3GP conversion.
2. Databases are 100% identical with VW standard. There is no ingeration in originality of the databases.
3. This package is CHECKED. There was a successful upload.
4. Don't use Green Menu, You need to use User Defined method.
5. Don't ask how to upload it into Your RNS. There's answer for that in the internet.
6. If Your map won't work after 3-4 minutes after the update don't panic. It means You need to activate it. This scripts slays process which checks if the maps are activated. Here, it will make Your maps work:

or unblocker from DrGER:

7. Please RESHARE. If You've downloaded it and it's working, upload it to any possible server to share with other people. Even You can post alternative links in here. Don't let other people to earn money on this.
8. Have no knowledge if TMC works, but it should.
9. If someone is successful with updating, please don't be shy and let us know. If it fails, also please send a post.
10. It looks like AN (australian) firmwares are identical with ECE (european) ones. It works for P0824 nad K0821. It won't work with old firmwares.
11. If You don't know what to do please ask for help. No shame in it, but don't be lazy.
12. Ths map is from 2021. The newest means there's no other higher available version. Probably there won't be any.
13. Don't use MacOS to extract or upload Your files onto SD Card!
14. When You'll have 03623 or 03276 errors in 5F module after the update I can help fix them (one of them requires VCDS).

This is how to solve one error:

This is how to solve the other:

15. Use solid SD Card, not a microSD with adapter.
16. Here's P0824 firmware (for ROW - Rest of World and ECE - Europe only):

This is how the Australian maps look like after the update (Thx to @Steve_L):
Ecoregion Map World Slope Rectangle

Property Ecoregion Map World Land lot

This is the system information You get after making a successful maps update:
Font Rectangle Screenshot Multimedia Terrestrial plant

P.S. Feel free to ask me any questions (except for stupid ones).
See less See more
  • Like
Reactions: 4
1 - 20 of 214 Posts
I have only ever done a map and/or firmware update via the Green Menu.
You mention that users should use the "Standard Method".
Could you please explain what the Standard Method is?

Thanks for providing the file ;)
Hey Guys

How do you exit engineering mode?

Found it, phone + nav + central buttons

so you have managed to update it successfully?
Thanks OP!

I was game enough to try this today, no issues. Used a USB rather than SD card, took about 15 minutes.

View attachment 256450
care to give us "frightened" souls a blow by blow description of how you did it please?
Thankyou. Was giving to give you a week of using it then check in. :(
how did you go with the activators @BriefObsessions ?
Well @Steve_L , are you going to give it a go? I'd prefer to see another successful installation before I fiddle around with mine. I'm not confident with fiddling with my Treg's software guts. :giggle:
not yet ;)
I just tried downloading that file.
I used Google Chrome.....
File size is 722mb (compressed)
When it's downloaded, I'll send you another link ;)
Well, after Wayne @BriefObsessions had success with the map install, I thought I would give it a go.
Downloaded from the links no problems.
Tried via full size SD Card - nope.
Put the map files onto a DVD-r - nope.
Put the files onto a USB stick - nope.

Each time I was getting this result:
Automotive design Audio equipment Gadget Vehicle Radio

FWIW here is my firmware version:
Automotive design Vehicle Radio Satellite radio Vehicle audio

Any thoughts @Lysy ??
See less See more
My thought is that Your SD Card wasn't formatted with FAT32 and/or You used MacOS for extracting the archive. It's the first thing to check.
FAT32 formatting.
I made sure of that. And no, I didn't select MacOS with the download. ;)
I meant did You use Windows or Apple computer to extract the files? Was Your card bigger than 32 GB?
Windows PC (Windows 10)
8Gb card and also 8Gb USB
Have You previously had any issues with reading f.e music from SD Cards? NO
Have You ever made a successful update of the firmware or maps? YES
Did You try to use SD Card Slot 2 and select it during the update? YES
Did You remove all USB, SD Card from second slot, SIM Card from the main unit before the update? There was still a SD Card in slot 1 which has my music on it. That was still there. The Map Update card was placed in Slot 2.
Please remove everything and use slot 1.
OK.... will attempt tomorrow and let you know. Thanks ;)
Map has been successfully loaded. My problem was that I did not have the contents of the map file loaded to the Root Directory. I had the contents inside a folder named "RNS850 8R006... " Once I brought the contents up to the Root Directory (no other files/folders on the USB Stick) it worked.

The maps displayed ffor a short while, then came the screen warning " ..... needs to be activated by Dealer"

I tried to load the Unblocker (as provided in post #28) but I get the same message as before "Medium is currently not available". 8Gb SD Card and 8GB USB tried. Both formatted to FAT32. Original file downloaded onto Windows 10 PC/Laptop.

Do I need a new unblocker file or should I use the Activator file you provided in Post #1?
We decided to take the car for a spin (150klm return journey - just to have lunch ;) ) as I noted that after receiving the message " ..... needs to be activated by Dealer" - further use of the SatNav was permitted with no further requests for activation.
Missus said "take it for a drive". So, we did.
The unit behaved flawlessly. No issues whatsoever.
The screen map is now shown with a new colour scheme (I like). The MFD dispaly is now further enhanced with more detail than was provided before, and a new (improved) colour scheme.
Speedometer Odometer Tachometer Car Motor vehicle

I am very happy with the improvement. THANKS FOR YOUR WORK @Lysy

@DrGER thankyou for your post. I'm not sure whether to still 'pursue' the activtion. Also, the navdb unblocker your referred to (yours) - is that the link you provided in post #52?
See less See more
  • Like
Reactions: 1
Yes....POI (Special Destinations) are working. Also my saved Favourites and previous destinations from usage of the 'older' map have been retained.
we have "Euro" firmware because our radio stations use the same incremental Hz steps as Europe. America/Japan are not suitable for our units, as you would not be able to tune/store your favourite FM/AM radio stations.
Also, have You noticed any new elements (roads, pois) on the fresh maps? These new look also has smaller road signs. And You'll be able to view information about traffic jams in between Your dials (if Your TMC online works).
Yes, recent major roadworks (2020/21) are showing on the maps and POIs (what I have searched thru so far) appear to be more up to date. Haven't checked TMC yet, but confident it will be working (will check this morning)
The unblocker script ZIP mentioned in Post #28 is mine. The link in Post #52 is for the QNX VM image (unrelated to nav database updates), useful for inspecting the software update packages provided by the vendor (Harmon-Becker). --g
I tried the "unblocker" again.
Formatted USB Stick and SD Card to FAT32. Re-downladed and extracted the files so that only the required files were on the media in Root Directory.
RNS keeps showing the same warning/result: "Medium is currently not available".

@Lysy TMC is working fine.
@Steve_L : The unblocker patch installer is a QNX shell script that runs when the SD card is inserted into either slot. Just start your RNS, let all the functions start fully, then insert the SD card into an open slot & follow the screen prompts to installed the patch that deactivates the normal MMI3G nav database activation process. Remove the SD card when prompted & restart the RNS. --g need to go into Engineering Menu to "upload/update"?
Thanks @DrGER
I was not aware that it was a matter of simply inserting and watch/wait.
I have confirmed by the logs on the SDCard. Navblocker/Activation completed successfully.
Many thanks @Lysy and @DrGER for your support, patience and assistance.

I will make some downloads (& full instructions) available for Aus/NZ players shortly.
  • Like
Reactions: 4
1 - 20 of 214 Posts