Club Touareg Forum banner

361 - 380 of 421 Posts

·
Registered
Joined
·
4 Posts
I just purchased a used '04 Egg. It came with the CD based navigation with the digital 11 speaker amp. I've been reading several posts around about adding the/an Android-based head unit, and the gigantic wiring nightmare that entails to keep the 11 speakers all working.

One suggested tregradios.com, which boasts a hassle-free plug and play with a head unit. The issue is that I don't want to spend $700+ on a head unit, when I know there are cheaper options.

Does anyone know where to purchase the amplifier adapter separately?

You can buy cheaper Android-based navigation units on Amazon, so I was wondering if anyone has ever done this, or just bit the bullet and bought the whole head unit.
Re the TREGRADIOs, I purchased the unit for my Touareg 2005 DVD navigation system. The people were very helpful, however; it wasn't a complete plug & play & not all the promised features worked where I mention:

Cons:
1- I had to get the help of a professional Shop to do the job.
2- they had to cut some wires to complete the job.
3- they had to cut a plastic column that held the back of the old unit to fit.
4- They had to insert a kind of support under the unit to hold straight.
5- the unit went into place but the clips that hold its front side didn't work. So I can simply retract it from its place by the tip of my fingers.
6- Only the volume worked from the steering wheel & No MFI display for the radio.

Pros:
1- The sound is good & all 11 speaker worked.
2- the map worked well.

I am still working on getting the internet connection which was not easy to do till now. The DVD is not working correctly where I am trying to figure out how to solve the problem (it is showing the picture in its negative form). Connecting the Ipod is OK but I cannot select the songs, Albums, etc. after plugging it. It only works by itself. I also had to re-plug the Ipod to start in case I was using the radio & decided to shift to the Ipod.


I also purchased a wireless back up camera which works with interruptions. TregRadios claim the it is due to Cell phone interference!


Regards

Dureid
 

·
Registered
Joined
·
3 Posts
Re the TREGRADIOs, I purchased the unit for my Touareg 2005 DVD navigation system. The people were very helpful, however; it wasn't a complete plug & play & not all the promised features worked where I mention:

Cons:
1- I had to get the help of a professional Shop to do the job.
2- they had to cut some wires to complete the job.
3- they had to cut a plastic column that held the back of the old unit to fit.
4- They had to insert a kind of support under the unit to hold straight.
5- the unit went into place but the clips that hold its front side didn't work. So I can simply retract it from its place by the tip of my fingers.
6- Only the volume worked from the steering wheel & No MFI display for the radio.

Pros:
1- The sound is good & all 11 speaker worked.
2- the map worked well.

I am still working on getting the internet connection which was not easy to do till now. The DVD is not working correctly where I am trying to figure out how to solve the problem (it is showing the picture in its negative form). Connecting the Ipod is OK but I cannot select the songs, Albums, etc. after plugging it. It only works by itself. I also had to re-plug the Ipod to start in case I was using the radio & decided to shift to the Ipod.


I also purchased a wireless back up camera which works with interruptions. TregRadios claim the it is due to Cell phone interference!


Regards

Dureid
Hi Dureid,

I'm considering buying this head unit. Did you resolve the issues you were having with it? Do you recommend it?

Also, how long ago did you order it?

The reason I ask it that when I go on their website, and press "Contact Us" it goes to a blank page, with no other option to contact them. I'm hesitant to give them $400 without anyway to contact them for support...

Do you have any current contact info for them?

Thanks in advance for your consideration!

D
 

·
Premium Member
Joined
·
712 Posts
You can contact us at [email protected] The contact us page works now.

Hi Dureid,

I'm considering buying this head unit. Did you resolve the issues you were having with it? Do you recommend it?

Also, how long ago did you order it?

The reason I ask it that when I go on their website, and press "Contact Us" it goes to a blank page, with no other option to contact them. I'm hesitant to give them $400 without anyway to contact them for support...

Do you have any current contact info for them?

Thanks in advance for your consideration!

D
 

·
Registered
04 V8 T1
Joined
·
966 Posts
Has anyone gotten any of these to work 100% With all speakers working and no drain to the battery? 38 pages is a little long. We need some Spark notes!
 

·
Registered
Joined
·
346 Posts
Has anyone gotten any of these to work 100% With all speakers working and no drain to the battery? 38 pages is a little long. We need some Spark notes!

1. All speakers work. Some has the humming, which can be fixed either by grounding the RCA, or an inline filter. For me, it's a quick firmware and a better amplifier app (ViperFX) after rooting the OS.

2. Battery drain will occur regardless, between 0.5A to 5.2A, based on what you've done as mods internally, in conjunction with the HU. If you only have the HU, you still want to monitor if there is really is a battery drain by performing a parasitic drain test. Always know your vehicle from the inside out.
 

·
Registered
Joined
·
346 Posts
True. Either put in some work, or bring it to the local audiophile store, get charged $400 for the unit plus $350 for the labor, come back a few more times to resolve the issues in which you burn more hours of your time. Best yet, stick with the old unit and be happy without the new tech add-on.
 

·
Registered
Joined
·
3 Posts
I bought the "Comet 5" from Tregradios.com, and I love it!! I think they sell it under many different names, but if you google Rockchip PX3, that's the one. Everything works flawlessly for me, Navi, Pandora, DVD, Youtube, hands free calling, bluetooth, back up camera. I don't even use the bluetooth for music anymore because the music apps are installed in my head unit. I just use my phone as a hotspot. It was completely plug and play for me everything worked when I plugged in the harness, including my steering wheel controls. With my Treg, I had to cut a little bit out of the OEM plastic cage the HU sits in to allow the cabling behind it to fit, and allow it to sit flush, but now it looks factory. Also you can change the lighting to any color and it matches all my other buttons.

The only thing that took any effort was the GPS antenna, which was really easy, and the back up camera, which was less easy. I originally went with the wireless camera, but it only worked sporadically, and stuttered a lot. I decided to hardwire it and now it works perfectly. Running that wire to the front was a pain in the ass but worth it.

My only complaint is the head unit didn't "snap" into the dash. I can just wiggle it a little and pull it out. Other than that, I love this thing, highly reccomend!
 

·
Registered
Joined
·
27 Posts
Anyone else buy that one and not have any problems?
Everyone have some problem unfortunately...and not install this HU
I am read all 38 pages but not detected 3 very important things....,everyone is dealing a physical installation and that is less important !!!!

1. Does anyone work SEARCH button on steering wheel or NOT ????? (Or only volume button work)

2.Did is possible to resolve drive 11 speaker through factory amplifier without "buzzing-humming" that comes right away when ignition is switch on and continues with engine on,(NO ALTERNATOR "HUMMING-BUZZING" with engine on),because that "buzzing-humming" is very frustrate and loud ???? If it is possible please put link for components that I need to resolve,to I bay ????

3. Is it possible to HU stay power on if ignition is switch off....like factory HU...very important item because bad quality CAN BUS box ....or what ?????

That 3 question is important for everyone and will mean a lot to use,so please experts to answers on it,I would like to pay somebody to resolve,or explain these 3 problems ??????

Thanx very much !!!
 

·
Registered
Joined
·
346 Posts
1. Does anyone work SEARCH button on steering wheel or NOT ????? (Or only volume button work)
Older CANBUS translators v1.0 and v1.1 don't work. Haven't play with the newer release of 1.5 and 2.0, which is not compatible with my existing unit.

2.Did is possible to resolve drive 11 speaker through factory amplifier without "buzzing-humming" that comes right away when ignition is switch on and continues with engine on,(NO ALTERNATOR "HUMMING-BUZZING" with engine on),because that "buzzing-humming" is very frustrate and loud ???? If it is possible please put link for components that I need to resolve,to I bay ????
Yep. Grounding of RCA cable (by wrapping a 16 or 18 gauge wire around the outside of the RCA and connect to a clean metal frame). One of member manage to find an impropriate black (ground) wire that was spliced into the adapting harness, which created the bad grounding. He grounded that wire properly, and *poof* no more sound.

3. Is it possible to HU stay power on if ignition is switch off....like factory HU...very important item because bad quality CAN BUS box ....or what ?????

This one had been discussed in so many forums that I lost count of the hours I spent in researching to find the resolution. To this very day, the answer is, NO. the power remains ON, but the CANBUS translator v1.0 and v1.1 don't see it that way. This is the lack of ability for the translator to communicate with the onboard CANBUS. I've done over 2 dozens rewiring, mods, and hacks to defeat the power auto-off to the HU, but could not. The simple thing to do is to press any of the search button (+/-/menu) and the HU wakes up, after the onboard CANBUS place the HU to sleep after 30 seconds of idle time.

However, I did successful place the HU on a complete power on state by removing the CANBUS translator, and some oddball wiring in which I've attempted to retrace, but be warned, the AMP and HU WILL be ON ALL THE TIME. AMP will be turned off the moment you pull the key. The HU will be on always until you manually turn it off. Drained my battery completely once overnight when I forgot to shut it off after coming home from work. No bueno.
 
  • Like
Reactions: boki

·
Registered
Joined
·
346 Posts
Step two, get a phone mount, and use your phone.

Step 3, enjoy your sanity.
 

·
Registered
Joined
·
27 Posts
So grounding RCA outside resolve "humming" that appears immediately after ignition on,when amplifier switch on ?????? (now I do not mean on humming from alternator)
Do I need to ground all RCA connectors video-audio or just only those that are connected ? I have 11 RCA connectors.
I saw the pictures from that ONE members but in his text write GREEN connector wire for grounding but on pictures he show blue connector with Black wire ....These two link :

http://www.clubtouareg.com/forums/f45/upgrading-head-unit-249521-16.html#post1739954
http://www.clubtouareg.com/forums/f45/upgrading-head-unit-249521-16.html#post1739978

That is my HU :

https://www.aliexpress.com/item/Android-7-11-2DIN-Car-DVD-Touareg-for-VW-Touareg-2004-2009-2DIN-CAR-DVD-GPS/32815097617.html?spm=a2g0s.8937460.0.0.haMJ7j

This HU work without any bugs....,only problem is that three steps about which I wrote....!!!
Is that HU critical for root ?
 

·
Registered
Joined
·
346 Posts
I bought the "Comet 5" from Tregradios.com, and I love it!! I think they sell it under many different names, but if you google Rockchip PX3, that's the one. Everything works flawlessly for me, Navi, Pandora, DVD, Youtube, hands free calling, bluetooth, back up camera. I don't even use the bluetooth for music anymore because the music apps are installed in my head unit. I just use my phone as a hotspot. It was completely plug and play for me everything worked when I plugged in the harness, including my steering wheel controls. With my Treg, I had to cut a little bit out of the OEM plastic cage the HU sits in to allow the cabling behind it to fit, and allow it to sit flush, but now it looks factory. Also you can change the lighting to any color and it matches all my other buttons.

The only thing that took any effort was the GPS antenna, which was really easy, and the back up camera, which was less easy. I originally went with the wireless camera, but it only worked sporadically, and stuttered a lot. I decided to hardwire it and now it works perfectly. Running that wire to the front was a pain in the ass but worth it.

My only complaint is the head unit didn't "snap" into the dash. I can just wiggle it a little and pull it out. Other than that, I love this thing, highly reccomend!
Good to know. That unit has the built-in module for the CANBUS negotiation, without being a standalone unit, simplifying things much more, with a simple firmware upgrade/update to fix any error. We're stuck with the older gen units, and just have to deal with the small headaches during installation. Once we discovered the issues, for me anyway, it all worked out, minus a few bells and whistles with the steering column controller.

Did you manage to get all the steering buttons to work with the HU?


So grounding RCA outside resolve "humming" that appears immediately after ignition on,when amplifier switch on ?????? (now I do not mean on humming from alternator)
Do I need to ground all RCA connectors video-audio or just only those that are connected ? I have 11 RCA connectors.
I saw the pictures from that ONE members but in his text write GREEN connector wire for grounding but on pictures he show blue connector with Black wire ....These two link :

http://www.clubtouareg.com/forums/f45/upgrading-head-unit-249521-16.html#post1739954
http://www.clubtouareg.com/forums/f45/upgrading-head-unit-249521-16.html#post1739978

That is my HU :

https://www.aliexpress.com/item/Android-7-11-2DIN-Car-DVD-Touareg-for-VW-Touareg-2004-2009-2DIN-CAR-DVD-GPS/32815097617.html?spm=a2g0s.8937460.0.0.haMJ7j

This HU work without any bugs....,only problem is that three steps about which I wrote....!!!
Is that HU critical for root ?
Correct. The humming sound comes from the poor ground altogether, whether the engine is on or not. The moment the amp switches on, the hum occurs at the same decibel, without the high-low whining sound from the alternator/engine. It's just poor grounding all around. I wish I took photos before I shoved my HU back into the dash, and hate pulling it back out, since it takes me a good 30 minutes just shoving it back in properly.

I have 3 areas I grounded:

1. The RCAs. Instead of wrapping the wires around the RCA alone, I have the female-couplers that I join the RCA males together. I solder (using silver solder) to ensure solid connection regardless of the vibration/heat. This ensure all possible improper grounding going into the amp is dealt with. Since you have 11 RCA cables, you got some major cabling nightmare.Track down the RCA that cables that cause the humming due to poor grounding. It may be one, or it may be all 11. However, check out #2 and #3 before the RCA.

2. Grounding of the HU ground (black) wire. This grounding prevent any improper grounding from the HU to the body. Rather than worrying about it, I did it just for my peace of mind. I simply split the ground going into the harness, and ground solidly into the clean surface (no paint and completely exposed metal) of the vehicle's body.

3. Grounding of the adapter's harness. Remember, you got tons of unit coming from different areas, by different sellers, but pretty, the same unit from two or three manufacturers in Asia. I'm not sure if it's the lack of coffee or qualify assurance, but units are not properly wired based on the diagrams. Make sure to trace all wires on the original harness to their respective connected adapter's harness. For additional measure, I also re-ground the original harness ground wire.

For me, #1 works in reducing 80%. #2 eliminated the humming to unnoticeable level. #2 eliminated to the point I don't even know if it exists. Rooting, updating firmware, and installing ViperFX completely dismiss the humming. So, it's not just one, two, three, or extra, but all steps were taken.

Remember, we're running on old gen units. You have a newer unit, but I see that you're using a CANBUS translator v1.1, or possibly v1.2, based on the OS 7.x. If it's v1.0, man, you're lucky to only have the humming as an issue.
 
  • Like
Reactions: boki

·
Registered
Joined
·
27 Posts
2# But ground wire on factory harness already going directly from car body and on that wire connect black wire from HU harness,so I don't see point of that grounding...but I try that....
3# I do not understand very well what to ground here,on original harness I have just 4 wires + , - (brown wire on factory harness and black wire on HU harness),CAN-HI,CAN-LO.....please if you can explain little more ? :eek:ops

When I puled out my HU I look wich version CAN BUS I have...
Wich version is at you ????

If you ever puled out your HU please take pictures that grounding,because it does not fall to my mind how to ground so many RCA on easy way.....Please.
 

·
Registered
Joined
·
346 Posts
2# But ground wire on factory harness already going directly from car body and on that wire connect black wire from HU harness,so I don't see point of that grounding...but I try that....
When you have a poorly ground hardness, you have interference feeds looping throughout the entire electrical system. You be surprised how bad the grounding wires are hooked up in the vehicles can be during manufacturing processes.

3# I do not understand very well what to ground here,on original harness I have just 4 wires + , - (brown wire on factory harness and black wire on HU harness),CAN-HI,CAN-LO.....please if you can explain little more ? :eek:ops
Not sure how your harness was set up, but there are a hell lot more than 4 wires. See my attached photo on the original harness.

When I puled out my HU I look wich version CAN BUS I have...
Wich version is at you ????
My HU's CANBUS translator box is v1.0. See photo.

If you ever puled out your HU please take pictures that grounding,because it does not fall to my mind how to ground so many RCA on easy way.....Please.
[/QUOTE]

Understood. I'll take tons of photos next time. I'm about to upgrade my rear window camera soon. I'll rip things apart and resume to take photos then of all the mods I've done until now.
 

Attachments

361 - 380 of 421 Posts
Top