Club Touareg Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
493 Posts
Hey guys.. I finished my steering wheel swap last weekend and had a few pictures and video to share. I initially had an issue with the horn sounding while turning the wheel. Seems like maybe my first installation of the airbag pinch a contact or something. Slid it back off and put even force to pop it back in and it seems fine now. Horn functions only when pressed. All functions on wheel seem to be working fine. Despite several codes including horn ground short an ACC fault and another unspecified. I am hoping I have been able to clear the faults after driving 50 miles but I will see on next scan. Haven’t tried the ACC yet but everything else seems fine. My biggest concern at the moment is the fitment of the airbag. I can’t remember how it was on my old wheel (guess I should have been more observant).. but this one seems kindof loose and the gaps seem rather large. I was wondering if I damaged the springs on the two clamps trying to get the bag off? I was hoping someone could tell me whether this seems right. The wheel is clamped on but it wiggles some. Thanks so much for anyone willing to help me out.
 

Attachments

·
Registered
Joined
·
493 Posts
No need to replace the modules. Not sure if that’s your problem but I also swapped the lane departure warning system into mine and simply plugged in the device. It works fine on mine. But I doubt the module would be an issue.. maybe the coding is not correct.
 
1 - 4 of 4 Posts
Top