Club Touareg Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
Many issues here. I needed to remove the pass side air box to get at the two rear bolts on the headlight bracket to adjust the bracket, which I did. Put everything back and I got a rash of errors on the console when I started it up to test. I checked a large cable junction right under the Mass Airflow meter, saw one connection may be askew, and removed that half of the airbox (like you are changing the air filter element) and pushed it back into place. Checked the others, seem ok. Started up again, fewer warnings but I did get a traction control system light.

Driving today, idle is low, about 600 rpm. The traction control light cleared. Engine smooth but lacking power. Accelerated onto frwy ramp today, the ACHTUNG! WARNING!!!! BRAKE ASSIST FAILURE!!! WORKSHOP!!!! SCHNELL!!! SCHNELL!!! error.

This behavior has happened before, when accelerating onto the frwy but without the traction control light. Also, the engine power hasnt come back, still feeling sluggish and the idle is still low. Usually idles around 700-800 rpm.

I did remove the Mass airflow meter connection but it is foobar then that ought to throw a CEL.

The idle and power could_be a vacuum problem? I did loosen and move the aux ABS pump several times. That has vacuum connections and a check valve. Could it be foobar?

BTW last fall I replaced the intake manifold linkages with the billet aluminum ones. Was like driving a twin turbo V8! But not now. It really does feel sluggish.

Any thoughts appreciated. My Touareg isnt Happy. 8-[

--Karl
2004 V8 T1
Somewhere in the Cascadia Subduction Zone
 

·
Registered
Joined
·
1,339 Posts
Many changes at once makes diagnosis more complicated. Touareg owners need a VCDS on hand to help.
 
1 - 2 of 2 Posts
Top