Club Touareg Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi all,

I have just installed a 9W7 bluetooth module on my 2009 Egg TDI and have an issue with it only playing MONO rather than STEREO. I have attached the 2 additional wires to the wiring harness and all the speakers play sound, it's just that it is not playing in stereo and is dropping a channel.

After doing some searching, for a while, there seems to be a similar problem with the RCD-510. I found this post: https://forums.vwvortex.com/showthread.php?5593793-2012-Passat-Bluetooth-Iphone-Stereo-vs-Mono/page18 It looks like VW put out a patch in tech bulletin 91-13-03 firmware 0008 that solved the issue.

Anyone know if there is a firmware upgrade for our RNS-510's to fix this issue?


Best,
stueveone
 

·
Registered
Joined
·
30 Posts
Discussion Starter #2
Hi All,

I just picked up a CD of 1140 firmware from ebay for $25 shipped. I am aware that 1142 might have some kind of reverse camera glitch, however, I'm not sure that 1140 has the same issue? I figured I would live with it if that's the case. I really would rather have stereo bluetooth audio streaming than the nice to have burry back up camera.

I'll let you all know what I find. There hasn't seemed to be much interest in this thread, at least post-wise, but maybe this can help someone else down the road.


-stueveone
 

·
Super Moderator
Joined
·
1,576 Posts
Hi All,

I just picked up a CD of 1140 firmware from ebay for $25 shipped. I am aware that 1142 might have some kind of reverse camera glitch, however, I'm not sure that 1140 has the same issue? I figured I would live with it if that's the case. I really would rather have stereo bluetooth audio streaming than the nice to have burry back up camera.

I'll let you all know what I find. There hasn't seemed to be much interest in this thread, at least post-wise, but maybe this can help someone else down the road.


-stueveone
your thread has been here for one day.


Please be patient. Also, sometimes, members are somewhat reluctant to share software. You may also find the firmware available thru other forums (that are more VW Nav orientated, rather than Touareg).
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
your thread has been here for one day.


Please be patient. Also, sometimes, members are somewhat reluctant to share software. You may also find the firmware available thru other forums (that are more VW Nav orientated, rather than Touareg).
Hi Steve, thanks for your response. Sorry, I didn't mean to sound impatient. I only meant that people on this forum are usually quick to respond if it is a popular issue/solution. Having had a previous similar post not receive any replies for several days, it didn't seem this topic was all that popular. However, I will still update my findings regardless in an effort to help someone in the future. All good, I already purchased a copy of the software.

Best
-s
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Hi All,

Just installed the copy of 1140 I got off eBay. Super easy. Get in the car. Turn on the stereo. I held the eject, day/night, guide combination which turned the stereo off. The directions stated that a red bar would appear top and bottom, however that never happened. After a few minutes, I went ahead and turned the stereo back on and just inserted the CD w/1140 on it. A couple "ok's" later and about 50 minutes and the CD ejected and the firmware was installed properly.

Result: I now have STEREO bluetooth audio!!!

Not sure what other changes this firmware will yield, some say the backup camera will work erratically. I'll report back on whatever good/bad/different I come across.


Best,
Stueve
 

·
Registered
Joined
·
29 Posts
Hello Stueveone, I'm trying to get the best match between my RNS-510 and the bluetooth module for my setup. Curious if you can tell me what RNS-510 you installed and what bluetooth module you used. I already ordered one unit (from a 11-12 Jetta) that I found probably wasn't gonna work, so I sold it. I already have the 9w7 harness with microphone on the way. Did you get full MDI and steering wheel controls. I have also seen a couple posts about swapping out the right control buttons on the steering wheel to the controls that include "phone" controls. Geezzz, this project just keeps getting more intricate.
 

·
Registered
Joined
·
996 Posts
BTW: if you install 1140 on a Touareg, it will actually install 1142. I did this on both my 2010 Touareg, and 2009 Eos. The same 1140 firmware CD. The Treg reports 1142, and the EOS 1140. It is likely due to hardware differences.
 

·
Registered
Joined
·
996 Posts
Depending on which version you upgraded from, 1142 will allow higher capacity SD cards. It will also enable the "backup camera does not turn on when you need it most" mode, which cannot be deactivated. Annoying, but only a couple of times per month.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #9
@Superfly - My RNS-510 was installed stock, so I can't provide much help in terms of upgrading or swapping out. I DID swap out the bluetooth module from a 9W3 to a 9W7. The only changes to the harness were adding 2 additional wires for stereo audio. The necessary changes to the firmware were handled by installing 1140 (or 1142 as Scuba pointed out).

I do not have MDI functionality and can only control the volume from my steering wheel. And the song information, title, artist, etc does not display on the head unit. But oh well. I didn't have any of that on my 2016 Subaru either, so I can manage. Totally feel your pain on the ever accumulating project details! Lots of ins and outs with these rigs I'm starting to discover!

-s
 
1 - 9 of 9 Posts
Top