Club Touareg Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Hello i started to install rain light sensor on my 2004 3.2 Trg which didn't have. I bought a new front glass because mine was cracked and i need to replace it anyway, so i bought a used RLS 1k0 955 559 r, andi-dazzle mirror and headlights switch with auto i take them from other Trg. Today i started to run the cables, mark enable RLS in VCDS but it gives me Error in VCDS "Rain light sensor impausible signal 008". Also my mirro did not dim. What it can be ? When i disconect pin 1 on RLS from the fuse, i clear the error and it's not showing the error again. this is the scheme which i used:

Mirror
1 pin - power to the 49 th fuse
2 pin - weight
3 pin - on the onboard power supply control unit 20 pin from 26 i think its for reverse
6-pin - on the ceiling in the 2nd pin 8-pin connector the ceiling.

RLS
1 pin - 12V fuse for the horn
2 pin - weight
3 pin - on the wiper control unit in the 5th pin 10-pin connector.
 

·
Registered
Joined
·
3,625 Posts
some ideas ?
You might be able to use this for some help...

rain light sensor retrofit and installation- VW DIY | VW TDI forum, Audi, Porsche, and Chevy Cruze diesel forum

Troubleshooting
First double check the wires, pin, and grounds. You can use a multimeter to check wire continuity. The rain sensor needs power, ground, and a communication wire to the CECM (Central Electronics Control Modeule) to function (in addition to coding).
Let us know how your project turns out.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
You might be able to use this for some help...

rain light sensor retrofit and installation- VW DIY | VW TDI forum, Audi, Porsche, and Chevy Cruze diesel forum



Let us know how your project turns out.
Yes, i use this thread for tips too. I double check the wiring pin 1 to +12v pin 2 to ground pin 3 to wiper motor.
only difference is that on the wiring diagram it was written that for 2004, pin 1 must be on 6 pin Q connector on CECM, but when i remove the module there was no Q connector so i decided do connect it to 12v, because for model 2005 it was writen in the wiring diagram that pin 1 need to be in fuse 7. I dont think that can be the problem.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #5
Hello, today i bought another used RLS with number 7L0 955 555 A , but again i get this error 01520 - Rain and light recognition senso (G397) 008 - Impausible signal. Any ideas what else can be ??
 

·
Registered
Joined
·
3,625 Posts
I suspect you have the wiring wrong.

You mention that the auto dimming mirror is not working and it is a simple, fully contained mirror that only needs +12V and ground to work. There is an output from this mirror that runs to the auto-dimming exterior mirrors. So, in theory, only 2 wires needed to make the auto dimming mirror work and 3 if you ran the output to auto dimming side mirrors. Add 1 more wire if you want it to light up with the interior lights.

If I had a factory wiring diagram for the mirror and RLS, I would share it with you.

Remember this is VW and VW has been known to move the wires around, so that parts would not be plug and play between two different VW models.
 
1 - 6 of 6 Posts
Top