Club Touareg Forum banner

Navigation unit not recognized?

4078 Views 5 Replies 3 Participants Last post by  heroncam
Just picked up my V8 Touareg this afternoon. First thing I tried was the Navigation unit. I popped in the CD for my area and the message displayed was:

Navigation system is being activated.

After a minute or two, the following message is displayed:

No navigation unit recognized.

Can't do anything with Nav at this point. Popping CD in and out just gives No nav unit message again. I know it worked when I test drove the vehicle last week! Any ideas?

1 - 1 of 6 Posts
spockcat said:
Did you try any of the other CDs? If not, try that. Once you get the nav to recognize the other CD, then pop in your region CD.
It has been reported by others that loading cd's 1-10 will perform a memory flash and that might just be what the doctor ordered from your condition. Give this a try and report nack to CT.
1 - 1 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.