Club Touareg Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
was working today on removing back side panels, want to put PP52DSP from this post:
http://www.clubtouareg.com/forums/f45/to-those-looking-for-a-plug-and-play-audio-upgrade-base-audio-only-223154-10.html

So i took out all required panels:
very back white pillar
passenger back top white pillar and the bottom black one
trunk right side panel
unplugged the light connector and 12v and back seat release connectors.
nothing else, didnt even touch HU or anything else.
Started the car to go pick up kids and the touchscreen is black/dead.
none of the buttons work, cant turn it on, no radio, nav, BT, anything, not even showing time, like it died
so i plugged the side panel cables back in, 12v, back seat release and side light, still the same thing. nothing
and i didnt even touch HU, just removed panels.
Any idea what may be going on?
really strange
 

Attachments

·
Registered
Joined
·
39 Posts
Discussion Starter #2
HU, radio, nav fuse

anyone knows which bank and which fuse is responsible for HU, radio, nav, on 2016 TReg?
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
all good, FYI

i removed fuse:
C47 - 10A - Information electronics control module 1 -J794-
Front information display control head -J685-
C51 - 20A - Radio -R-
and everything came back to life :)
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
nope, car is only 2 weeks old, fuse was perfect.
just took it out, waited few min, pop it back in, all good
no idea what happened, but that fixed it
at least now i know which fuses are responsible for the HU and screen
 
1 - 5 of 5 Posts
Top