Club Touareg Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Hoping someone can help...i retrofitted an rns510 in my 2010 v6 TDI..latest firmware and maps.. all was working well...

I went to turn on the car and noticed the unit is just dead, no lights, nothing on screen, no sound..

i put the delta radio I originally had into the truck and it works no problem (so i know its not a fuse or wire issue)

hoping its not a dead motherboard on it.

any ideas on what I can check?

I used VCDS and all modules are find except no communication with the RNS510 (which was working perfectly with no signs of issues)

i am going to take the rns510 apart and check all the capacitors but hoping to get some guidance on what I can check or test

any help is appreciated

thx
 

·
Super Moderator
Joined
·
1,585 Posts
It sounds like it is dead.


FWIW, it may be time to consider some of the Apple/Android friendly DDIN units that will fit into the area perfectly, and as a bonus, their facia design is extremely similar to the latest generation radio units. They are (predominately) plug and play and will offer a much more feature filled experience than the (ageing) RNS510 unit does.


The RNS is now longer subject to firmware updates (certainly for Euro/Aus-NZ) and no more map updates that I am aware of for the same regions.



There are threads on this forum for the Android unit and, here is an example I am referring to Volkswagen Touareg Android OS GPS Navigation Head Unit
Check to ensure it is compatible with your region for Radio frequencies etc.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #5
had the android unit, didn't like it....just installed this rns510 unit 9 months ago and just did the high rear camera oem retrofit 2 weeks ago... I like the rns510 and how it integrates so want to keep it.

will see if I can revive it or look for a replacement/service it.

im open to any suggestions

crazy how it died like that without any symptoms.
 
1 - 5 of 5 Posts
Top