Club Touareg Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all!

Quick question as i await my vcds cable. Picked up a Q7 (had an 08 Touareg back in the day) but wanted the V8 and air. So this Q7 is a 2008 shes done about 124k miles. The air springs seem to be holding pressure in dynamic/sport mode. The lower feature works fine for the rear. When placed into comfort the rear will rise yet the front remains low. the compressor continues to run until (what I imagine) is overheating and cycling off. The level sensors look to be good on the front but awaiting the cable to test. If one sensor were to fail would it foul the level for the whole front axel? or would only cause one side to drop? if it were a faulty valve block would the whole system decompress or just one and axel. Last but not least is there valves in the compressor that could be causing this fault? Given the age I plan on replacing the compressor and valve block regardless but would appreciate any input.

The members on this forum have always had a good hand at turning a wrench and I have always found much more information here than on any Audi forum :)
 

·
Registered
2005 Touareg V8
Joined
·
348 Posts
1) No need to replace the compressor. There is a rebuilt kit and you can just do that to freshen it up. I did it and the compressor barely runs and its much more quiet. VW Touareg 2002-2010 WABCO AIR SUSPENSION COMPRESSOR PISTON RING REBUILD FIX KIT | eBay - works for Q7 as well.
2) Possibly your residual pressure valve has gone bad. They allow air into the spring and open to allow air to escape. I would replace the valves FIRST before getting to the sensors
3) Make sure the sensors are well plugged in and tight into the upper control arms.
4) When my front left sensor went out, it affected my front right. I changed both and recalibrated and all was good.
5) if it were a faulty valve block, I would think it would affect the whole system.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
1) No need to replace the compressor. There is a rebuilt kit and you can just do that to freshen it up. I did it and the compressor barely runs and its much more quiet. VW Touareg 2002-2010 WABCO AIR SUSPENSION COMPRESSOR PISTON RING REBUILD FIX KIT | eBay - works for Q7 as well.
2) Possibly your residual pressure valve has gone bad. They allow air into the spring and open to allow air to escape. I would replace the valves FIRST before getting to the sensors
3) Make sure the sensors are well plugged in and tight into the upper control arms.
4) When my front left sensor went out, it affected my front right. I changed both and recalibrated and all was good.
5) if it were a faulty valve block, I would think it would affect the whole system.
Option 1 and 2 very cost-efficient, Will definitely give this a shot. Trying to breathe some life into the old girl only paid 5k the MMI unit was bad, it was just a bad amp. Would have loved another Egg there was nothing though for a T2 with the V8 here on the west coast. Thank you!
 
1 - 3 of 3 Posts
Top