Club Touareg Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I wanted to see if anyone here has some input on my air compressor issue with my tire inflator.
Okay the issue i am seeing is when i connect the spare tire inflation hose the compressor does not kick in. However it recognizes that the hose is connected and the display shows that its active, but the compressor will not kick in at all. It used to work and i believe it is the result of a repair on the air suspension system. I have checked the hose and the magnet is in the end of it and the compressor runs and operates the suspension without issues.
Now i don't have a repair manual so i am shooting in the dark on this one. The reason i think it is due to the previous air suspension repair is because it stopped working after it was repaired.
Last year i noticed that the front suspension was starting to leak down and i thought it was the valve in the air bag or possibly an air line. I usually try to do my own maintenance so put it up on the lift and couldn't find a leak. I was sure it had one i just couldn't see it and i would be driving it out of town for a few months for work.
About a week before i left i went ahead and dropped it off at the dealer told them i thought it was an air leak on the front end. It would always drop on the right front first. I had made an appointment and they were to have it all day. Now the nearest dealer for me is an hour away and my only back up vehicle was my old 85 ford f350. So needless to say i did not want to have to drive it for an extended amount of time.I drop it off and told them i would be back tonight to pick it up. After work i call and find out they never even looked at it, even though i told them i would be picking it up at closing time. Ended up having to leave it another day and got a call from the service manger the next morning asking if i knew that the suspension leaked down overnight? And is that why i had brought it it?
I said YES that is why it is in the shop! and it leaks down in 30 minutes not just overnight.
Well we are looking into it now! (this is 10am the second day)
Anyway long story short I am told they will call me back after lunch and let me know what they found. Of-course i never receive a call and have to call when i get off at 4PM.
Once again it takes a few minutes for them to find somebody that knows anything about my car. Finally the service manger comes online and tells me it wont be ready it needs the air suspension control valve and they had to order the parts.
I told them put it back together i am coming to get it and i would deal with it when the parts came in.
I go out of town with it and have the parts shipped to me. I install the control valve and order the compressor rebuild as well just in case. Of course it doesn't fix it, so I start hunting for the air leak. After another 3 weeks it gets so bad i can hear it and it will not air the front suspension up. I finally tear the front suspension apart to find the leak .
It ends up being a hole in the right front airbag, all be damned! just as i thought! Anyway I order the air bag and install it, just like that everything is working or so i thought.
About a month later i go to air up a low tire and the Tire Inflator doesn't work!
So i know that was long winded, but do you think it could be they wrong control valve? It was a different part number but was supposed to be an updated part? I guess i could put the old one in and see if it takes care of my problem?
Does anyone have a wiring diagram for the system or some items to check?
Like i said i am shooting in the dark without a repair manual.
 

·
Registered
Joined
·
20,430 Posts
In what way is the part number different?

The letter on the end of the number can change from A to B to C, etc., as the part gets upgraded, modified or a new supplier comes on board.
 

·
Senior Trex-Tamer
Joined
·
312 Posts
I have had my 04 be finicky in the past with trying to use the hose attachment as well. Sometimes it works ASAP, other times I have had to change the suspension setting or shut the doors and run the hose out an open window to appease the mighty gremlins that plague my Trex... Not sure if that offers you much in terms of helpful advice, but it's worth a try.

I myself just so happened to have the air suspension blow out last nite, got me out of bed when the blow off occurred. I'm now surfing the forums looking for advice and troubleshooting what happened and why my pump no longer wants to kick back on.
 
1 - 4 of 4 Posts
Top