Club Touareg Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I'm at my wits' end with my TDI. I have 96,000 miles on it and within the last two months, I've been plagued with CEL related to the emissions systems. It started with an ad blue heater failure: The dealer replaced the control module first, then the heater. VW covered most of the costs. Then started getting errors for a faulty NOx sensor. I ended up cleaning the sensor while I waited for a replacement to come in. I'm no longer getting the faulty sensor warning but now after a few hundred miles, it is throwing:

1 Fault Found:
9050 - SCR NOx Catalyst Bank 1
P20EE 00 [237] - Efficiency too Low
MIL ON - Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 2
Mileage: 154301 km
Date: 2016.05.31
Time: 09:54:39

For good measure, I replaced the NOx sensor with the one ordered. After driving about 70 miles, the same error came back. I'm well out of warranty and with the VW TDI remedy yet to be announced, not sure I want to dump a bunch of money to diagnose/repair the car. Trouble is, my registration is due so the car must be smogged.

I also noticed the Bank 1 NOx filter had soot buildup on it after just a few hundred miles - is that normal? A mechanic implied this could be an indication of a DFP issue.

I'd be grateful for advice or possible causes of the "efficiency too low" warning.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Well I pass smog after resetting the CEL but it came on again. The last time it came on, probably after a regen cycle, and astonishingly turned off after a few more restarts of the car. So I guess I'd suggest just keep driving after the CEL and see if yours also self-clears.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top