Club Touareg Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
First post here. I purchased my 2012 Touareg LUX TDI last month and have loved every second of driving it. My issue has been addressed on this forum in part, but I believe I am having something further happening. When I test drove the car I noticed the compass and navigation were way off. I ended up getting a good deal on the car so figured i'd either find a fix with the help everyone here or just use waze and google maps on my phone. My navigation says that I am in the Atlantic ocean, when in reality I am located in Tennessee. The compass has no idea what direction the car is pointed either. Mangs had a very helpful write up on the forum detailing how to replace the factory antenna with a Fakra C from Amazon. I followed his instructions and disconnected the factory shark fin antenna from the "navdrive" thing in the glove box, and replaced it with the Amazon antenna. I did a soft reset on the unit and drove around for a day with no improvement. I went by my local independent tech to see if any code needed to be cleared for the RNS 850 to start searching for satellites. They did a full scan and didn't see any codes for the nav. So I'm at a complete loss. What is concerning is that when I open the navigation page and press the "position" button on the screen - it shows 0/0 satellites. Which leads me to believe that it is a problem with the RNS 850 unit itself and not the antenna. My car is well out of warranty at 91K miles and I don't think its worth the money to replace the unit at the dealership. I may be left using waze or google unless anyone has some experience with this and can help.

Thanks in advance!
 
1 - 1 of 1 Posts
Top