Club Touareg Forum banner
1 - 1 of 1 Posts

·
Registered
2009 V6 TDi
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hello all. This is my first time posting. I have read many older threads about oil pressure switch issues, but can’t seem to find all the info I’m looking for in regards to the 2009 3.0 Tdi. The other day just as I was due for an oil change the “oil pressure don’t drive message and beeping started” I ran a scan with my buddies VAGCOM and this is what came up. No other malfunction/faults that seem related to the engine showed up. Another time I scanned it and it said it was intermittent. I've changed the oil to see if maybe it was so funky that it was causing the sensor to act up. Didn't help. Still getting warning after driving a short distance.

005707 - Oil Pressure Switch
P164B - 001 - Malfunction - MIL ON
Freeze Frame:
Fault Status: 11100001
Fault Priority: 2
Fault Frequency: 3
Reset counter: 255
Mileage: 141715 km
Time Indication: 0
Date: 2022.01.12
Time: 09:56:49

Freeze Frame:
RPM: 2268 /min
Speed: 41.4 km/h
Voltage: 14.59 V
Load: 33.3 %
Temperature: 63.0°C
(no units): 0.91
Temperature: 42.3°C

I’ve read there is a high and low pressure switch on other year models, but can't find info saying that the 2009s do. Do they?

From what I’ve read I'm needing to replace the oil pressure switch that is down near pulleys just above oil pan. It is a green 2 pin. Is this correct?

I've read these switches/sensors are covered under the “diesel gate” 120,000 mile “extended warranty”. Is this correct? Has anyone had their switches replaced at the dealership under this extended warranty?

Thanks in advance for y’all’s help on this.
Cheers!
 
1 - 1 of 1 Posts
Top