Club Touareg Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
In the last year I've had 3 speakers go bad and the head unit LCD go blank so it's time for some love and attention. I think I have the base, no nav, 10 speaker setup; there's no center speaker present and no obvious amp in the rear passenger side access panel. Not really looking for much of an upgrade (was thinking OEM speakers from vwdiscountparts) and head unit from crutchfield. I'm hoping the lack of amp means replacement to a bluetooth double din head unit will be relatively straightforward? Are there any pitfalls to avoid and is a touareg specific trim available anywhere to frame the unit nicely? Thanks, never done any ICE work before...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
Anyone have any experience of or opinion on Pioneer AVH-210EX. Easy to wire up to no amp/10 speaker system?
 

·
Registered
Joined
·
240 Posts
Hey man, since you don’t have Dynaudio you should have plenty of easy plug & play options. The Android units should be the easiest although they aren’t the fastest units unless you buy a good Chinese one with top specs internals.

Also, all these pioneers and other major name brands should be compatible so long as you double check to make sure whatever model ur buying is actually compatible with your specific year and trim level. It only gets complicated when you have Dynaudio.

You want the fastest easiest way, search eBay for Android head unit (Xtrons is an example) and you just pull old radio out and plug in new. If you have rear camera, then you lose that functionality and will have to install an aftermarket camera which would be better anyways cos the quality on factory cameras suck.

Hope some of this info helps. I’ve installed several different kinds in my 2010 Treg with Dynaudio and in the end just went back to OEM but the newer 2019 RNS510 unit with SSD memory rather than the slower HDD hard drives. I was having compatibility issues with Dynaudio and rear camera so going back OEM fixed my problems.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: francisb2
1 - 4 of 4 Posts
Top