Club Touareg Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I started the Treg today & the Nav Screen is not working. Radio is fine, I can select stations by rembering which button is what station. The backlight is on, I checked the fuses. Is this common, is it repairable? i'm afraid to pull fuses as I don't know if will lose its presets or worse ask for code.
 

Attachments

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Can anyone tell me if I will lose the radio station presets or lock up the unit if I pull the fuses?
 

·
Supreme Member
Joined
·
2,372 Posts
It's worth a try either way, though I believe it's not going to change anything.

Try it, and let us know.

What's the worst that can happen? Do you not have the radio code in the manual?
 

·
Registered
Joined
·
2,326 Posts
Sorry, but how can you enter the code without the display?
 

·
Registered
Joined
·
27 Posts
Discussion Starter #10
Ten minutes later I stopped for fuel and it died again. Later in the day while putting into park it started to display but flickering. I tried to attach a .mov video but its in valid. At the end of day the display looked like this.
 

Attachments

·
Registered
Joined
·
27 Posts
Discussion Starter #11
Last night I pulled the fuses, no change. Radio still works. I pulled the unit and removed the display head, could go no farther as it needs a torx bit smaller than #8 which I will look for today.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #13
I removed the display head & reseated the connectors & ribbon cables, no change. I ordered a display off ebay Sharp 6.5" LQ065T5AR01 TFT Display VW MFD2 for $150 delivered. New display has been working for several days now. you will need torx bits #20 #8 & #6 for the job.

 
1 - 13 of 13 Posts
Top