Club Touareg Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hey All,

First of all, I have read almost all discussions about this subject regarding the errors i mentioned, even in the other forum. However, I really cant find and locate the exact problem as to why those fault codes are happening to my car. There were times when I switched on the car, there would be absolutely no error or whatsoever in the dash and in the VCDS and other OBDII equipment im using, however, the next few days, it would be the opposite; I couldn't move the gear from P, ABS & EPS lights are on the dash, a System Fault and Brake Assist Workshop would be present as well, and there are times when the Oil Sensor Workshop appears too.

Now, I have tried the following possible solution below:

1. Change the Brake Light Switch - Unfortunately, after hours and hours of trying to locate the switch under the Driver's side dash, I have found no Brake Switch Light at all, it only has the Park Brake Switch. After searching for a diagram of the Pedal Cluster, I found this: http://www.oemepc.com/vw/part_single/catalog/vw/markt/RDW/modell/TOUA/year/2007/drive_standart/478/hg_ug/945/subcategory/945050/part_id/0/lang/e#sec_3 is it possible for the car to not have any actual Brake Light Switch???

2. Wiring Harness under Driver's seat could be damp/wet - I have checked the wiring harness accordingly but it is dry as it should be.

3. Battery could be weak? - The battery was just recently changed last May 2018 (currently using battery supplied by Bosch)

4. Check VCDS for Fault Codes - As I have mentioned, fault codes are kinda messed up as well, since, when the car is not in the mood (all errors i mentioned pops up) VCDS is throwing lots and lots of codes like "No communications with brake module, no communication with TCM, Steering Angle Sensor etc... etc.) but once the car is in the mood, none of these codes can be seen in VCDS.

My last option is to go to the stealership as I have lost all hope to actually identify the main problem if my car, But before that, I would like to hear your thoughts first about this matter.

Oh and for your information, I am currently in the middle east and I'm sure my car is EU spec (2007, V6 FSI 3.6L)

Thanks
Renz
 

·
Registered
Joined
·
1,415 Posts
Clear all the codes using the auto scan function. All codes.
Disconnect the battery for a few hours
Reconnect, clear all codes again. Drive the treg if it cooperates. Do a full scan then upload the content here.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Clear all the codes using the auto scan function. All codes.
Disconnect the battery for a few hours
Reconnect, clear all codes again. Drive the treg if it cooperates. Do a full scan then upload the content here.



Sent from my iPhone using Tapatalk
Okay, I'll do that when i get back home... Im currently using VCDS Lite btw...

Once, I've done this, I will upload all the fault codes on the system.

Thanks
Renz
 
1 - 3 of 3 Posts
Top