Club Touareg Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi All

Last Week, My 2.5 TDI (Registered 2008) was losing power and acceleration was sluggish to say the least. The Glow Plug Warning Light came on and the warning 'Engine Problem Go to Garage' continued to blink and ping.
Hardly No power when depressing the accelerator pedal but i was still able to get home slowly. Fuel Consumption high.
Took it in my VW Dealership, where i bought it and have had it serviced (long life) regularly by them since owning it, and they diagnosed a power fault problem with Turbo Boost Control and replaced the Turbo Solenoid Valve.
Driven the car for a couple of days and problem has come back again.
Any Ideas or similar problems encountered by anyone?
Also any help re refurbished parts i might need as i have lost my job recently and things are tight money wise.
Thanks to all in advance.
Smudger
 

·
Registered
Joined
·
20,430 Posts
I suggest you also post on www.mytreg.com the UK site.

UK VW dealer work is guaranteed for 1 year parts and labour and 2 years for parts. Get back to the dealer.
 

·
Registered
Joined
·
20 Posts
I've just experienced 'no power' when I press the accelerator. Then the engine response comes back to normal, then it goes (unresponsive) again. No warning lights on the dash. I abandoned my outing and got home OK, but it's got me puzzled. The only thing it reminds me of is when I had a blocked carb/fuel filter on a different car.
 

·
Registered
Joined
·
20,430 Posts
Get the car on VAGcom/VCDS and find out if any faults are recorded.

That's always the starting point really.
 
1 - 5 of 5 Posts
Top