Club Touareg Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
Hi,
Long story short...Tired of the dealers and their BS

My Platinum Warranty is up and after probably $25k+ billed to them and $5k billed to myself directly (even though I had a zero deductible) I still have an engine light on 5 years later. Turbos replaced at 38k miles already, new drive shaft at 50k miles, new glow plugs at same time as turbos etc

Treg runs fine and has full power after 67k miles but has a tandem pump leak and an engine light on since turbo replacement at 38k miles

I have a great backyard mechanic whom I have trusted with other vehicles for 20 years and I have seen what he is capable of. Leave it at that....

Anyway the engine is coming out and he will do the work.

What am I doing?
1) New Tandem pump (in hand) going on
2) Turbos coming off and being sent for rebuild (they are fine but the engine is coming out anyway)
3) Doing a full DPF delete with Malone tune.....not purchased as of yet
4) Replacing the 2 oxygen sensors and all glow plugs
5) Considering a new starter and drivers side fuel pump seeing as the engine will be out anyway

What I need and would appreciate is
A) Suggestions of what else to address
B) Links to help with the process. Yes I will do a search, but you guys are the gurus and can nicely stream line the process for me.

I want that engine light off once and for all and I fully believe that it is an oxygen sensor that is the main culprit.

I also have 2 intake gaskets, transmission maintenance kit, new fuel and oil filter on the way. My treg has ONE fuel filter even though it is an 06.

Any help appreciated to make this thing good again :)

Kind Regards
James
 

·
Registered
Joined
·
20,430 Posts
I'm not sure what you are thanking me for, but thank you too!

With what you have planned, I wish you good fortune in tracking down the annoying engine management light [or just take the bulb out??!!:twisted:]

Do take some pix if you can to add to this thread later.
 

·
Registered
Joined
·
12 Posts
Hi, I'm new to the forum. I have an 06 V10 TDI but from my understanding I thought only 07 and newer models had the DPF? I emailed VW customer service to ask specifically and they said that the 06 did not have a DPF. Is there a way to easily check and see if you have one or not? I posted this same question on another thread, just trying to spread it around to see if anyone has any insight. Thanks!
 

·
Registered
Joined
·
43 Posts
You might have already tried this but before you take the engine out, isn't it possible to somehow confirm that it really is the O2 sensor causing the MIL? What does the VCDS say?

Also, as noobytoogy has suggested, take plenty of pictures and post them here :smile:
 

·
Registered
Joined
·
1,294 Posts
All NA V10’s got the DPF’s beginning in 2006. Lie on your back and see the muffler lookalikes mid-way back, where mufflers used to be in the old days. You should definitely diagnose the CEL before engine r&r (have VCDS?)
 
1 - 9 of 9 Posts
Top