DEAD RNS510? - Club Touareg Forums
 
Thread Tools Display Modes
post #1 of 5 Old 12-12-2018 Thread Starter
Junior Member
 
Touareg: 2010 V6 TDI
Join Date: Aug 2017
Location: Ontario Canada
Second Vehicle: is not a VW
Posts: 64
Thanks: 10
Thanked 1 Time in 1 Post
Garage
DEAD RNS510?

Hoping someone can help...i retrofitted an rns510 in my 2010 v6 TDI..latest firmware and maps.. all was working well...

I went to turn on the car and noticed the unit is just dead, no lights, nothing on screen, no sound..

i put the delta radio I originally had into the truck and it works no problem (so i know its not a fuse or wire issue)

hoping its not a dead motherboard on it.

any ideas on what I can check?

I used VCDS and all modules are find except no communication with the RNS510 (which was working perfectly with no signs of issues)

i am going to take the rns510 apart and check all the capacitors but hoping to get some guidance on what I can check or test

any help is appreciated

thx

Treg life, loving it!
ZIMTDI is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-12-2018
Moderator
 
Steve_L's Avatar
 
Touareg: 2008 V6 TDI
Join Date: May 2012
Location: Mindarie, WA (OZ)
Second Vehicle: too many to list
Posts: 1,454
Thanks: 3
Thanked 64 Times in 59 Posts
Garage
Send a message via MSN to Steve_L Send a message via Skype™ to Steve_L
checked the fuse in the back of the RNS510?

2007 Touareg MY08 V6 TDI - Atacama Grey (Beige Trim) Tow Pack, RNS510, 9W7, Tint, V10 Exhaust Tips, Bilstein Sports Shocks, King Springs

2008 Golf MKV R32 (Deep Blue) 5dr, DSG, RNS, Sunroof, Carbon Fibre Rear Diffuser, Drilled/Slotted Rotor, Neuspeed F/R Swaybars, Unibrace, W.A.L.K., Tyrol-sport Chassis bolts, 9W2, Polar FIS+

2007 Yamaha FJR1300 (waaaay too many mods to list here) - The Mile Muncher
Steve_L is offline  
post #3 of 5 Old 12-12-2018 Thread Starter
Junior Member
 
Touareg: 2010 V6 TDI
Join Date: Aug 2017
Location: Ontario Canada
Second Vehicle: is not a VW
Posts: 64
Thanks: 10
Thanked 1 Time in 1 Post
Garage
All fuses on car and back of radio checked..all good.

Quote:
Originally Posted by Steve_L View Post
checked the
fuse in the back of the RNS510?

Treg life, loving it!
ZIMTDI is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 12-12-2018
Moderator
 
Steve_L's Avatar
 
Touareg: 2008 V6 TDI
Join Date: May 2012
Location: Mindarie, WA (OZ)
Second Vehicle: too many to list
Posts: 1,454
Thanks: 3
Thanked 64 Times in 59 Posts
Garage
Send a message via MSN to Steve_L Send a message via Skype™ to Steve_L
It sounds like it is dead.


FWIW, it may be time to consider some of the Apple/Android friendly DDIN units that will fit into the area perfectly, and as a bonus, their facia design is extremely similar to the latest generation radio units. They are (predominately) plug and play and will offer a much more feature filled experience than the (ageing) RNS510 unit does.


The RNS is now longer subject to firmware updates (certainly for Euro/Aus-NZ) and no more map updates that I am aware of for the same regions.



There are threads on this forum for the Android unit and, here is an example I am referring to Volkswagen Touareg Android OS GPS Navigation Head Unit
Check to ensure it is compatible with your region for Radio frequencies etc.

2007 Touareg MY08 V6 TDI - Atacama Grey (Beige Trim) Tow Pack, RNS510, 9W7, Tint, V10 Exhaust Tips, Bilstein Sports Shocks, King Springs

2008 Golf MKV R32 (Deep Blue) 5dr, DSG, RNS, Sunroof, Carbon Fibre Rear Diffuser, Drilled/Slotted Rotor, Neuspeed F/R Swaybars, Unibrace, W.A.L.K., Tyrol-sport Chassis bolts, 9W2, Polar FIS+

2007 Yamaha FJR1300 (waaaay too many mods to list here) - The Mile Muncher
Steve_L is offline  
post #5 of 5 Old 12-12-2018 Thread Starter
Junior Member
 
Touareg: 2010 V6 TDI
Join Date: Aug 2017
Location: Ontario Canada
Second Vehicle: is not a VW
Posts: 64
Thanks: 10
Thanked 1 Time in 1 Post
Garage
had the android unit, didn't like it....just installed this rns510 unit 9 months ago and just did the high rear camera oem retrofit 2 weeks ago... I like the rns510 and how it integrates so want to keep it.

will see if I can revive it or look for a replacement/service it.

im open to any suggestions

crazy how it died like that without any symptoms.

Treg life, loving it!
ZIMTDI is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Club Touareg Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome
 

VW Touareg News Delivered to your Email!

Stay up-to-date with Touareg news in your inbox.

unsusbcribe at anytime with one click

Close [X]