MAF WIRING HELP NEEDED 05 Touareg - Club Touareg Forums
 
Thread Tools Display Modes
post #1 of 6 Old 1 Week Ago Thread Starter
Junior Member
 
Touareg: 2004 V6
Join Date: Dec 2015
Location: New york, Usa
Second Vehicle: Still looking
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
MAF WIRING HELP NEEDED 05 Touareg

2005 Touareg 3.2

I have an issue with the MAF in my car. Been trying to diagnose it for a long time (honestly gave up for a while)
Originally the car was running 2 codes, p0102 and the other i forget but it was for throttle correlation
I changed my MAF and the problem came back worse and it began stalling and smelling like gas, so we changed the throttle body as well
everything has been running great since then, but the CEL for p0102 never went off
stopped by my mechanic yesterday to get it checked on the vag com

Said it had 0 air flow, and was running on a closed loop
since we already changed the MAF, he said he's certain its a broken wire going to the sensor, but that it was too late in the day (and possibly not worth me having him do) to begin chasing the wire, as it can be anywhere between the maf and the systems computer,

Anyone have any experience with this issue? Or would anyone by any chance have a diagram that shows me where that wire runs?

Or any other ideas as to what can be going on?

Thanks in advance
tonycanale26 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 1 Week Ago Thread Starter
Junior Member
 
Touareg: 2004 V6
Join Date: Dec 2015
Location: New york, Usa
Second Vehicle: Still looking
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
bump?
tonycanale26 is offline  
post #3 of 6 Old 1 Week Ago Thread Starter
Junior Member
 
Touareg: 2004 V6
Join Date: Dec 2015
Location: New york, Usa
Second Vehicle: Still looking
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Also does anyone know if there is a fuse or a relay for the MAF?
tonycanale26 is offline  
 
post #4 of 6 Old 1 Week Ago Thread Starter
Junior Member
 
Touareg: 2004 V6
Join Date: Dec 2015
Location: New york, Usa
Second Vehicle: Still looking
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Think i meant to say zero voltage going to the MAF
tonycanale26 is offline  
post #5 of 6 Old 1 Week Ago
Touareg Enthusiast
 
Ionman's Avatar
 
Touareg: 2004 V6
Join Date: Jan 2017
Location: SoCal
Second Vehicle: a bicycle
Posts: 260
Thanks: 0
Thanked 15 Times in 15 Posts
Sorry Tony, didn't see this post. Got busy with projects. Did you use a OBD scanner to pull the code, or did you use the vagcom?

Vagcom can get more live info than the scanner. Aside from that, remove the MAF sensor. Perform a continuity test. That MAF sensor must have a current going through it. Plenty of videos on the MAF sensor testing. Pick on.

If sensor works, check the wire harness/loom for wire exposures/cracks/shorts.

- Leo

When life offers you a blessed world to explorer, why stay home and see the adventures through others' eyes.
Ionman is offline  
post #6 of 6 Old 1 Week Ago
Touareg Enthusiast
 
G6mdxvct's Avatar
 
Touareg: 2005 V6
Join Date: Feb 2014
Location: USA
Second Vehicle: VW 2
Posts: 466
Thanks: 0
Thanked 6 Times in 6 Posts
Quote:
Originally Posted by tonycanale26 View Post
2005 Touareg 3.2

I have an issue with the MAF in my car. Been trying to diagnose it for a long time (honestly gave up for a while)
Originally the car was running 2 codes, p0102 and the other i forget but it was for throttle correlation
I changed my MAF and the problem came back worse and it began stalling and smelling like gas, so we changed the throttle body as well
everything has been running great since then, but the CEL for p0102 never went off
stopped by my mechanic yesterday to get it checked on the vag com

Said it had 0 air flow, and was running on a closed loop
since we already changed the MAF, he said he's certain its a broken wire going to the sensor, but that it was too late in the day (and possibly not worth me having him do) to begin chasing the wire, as it can be anywhere between the maf and the systems computer,

Anyone have any experience with this issue? Or would anyone by any chance have a diagram that shows me where that wire runs?

Or any other ideas as to what can be going on?

Thanks in advance
The wiring should lead to the ECM bottom of windshield on left side underneath the cover. When the MAf is not working the ECM calculates a substitute value. The ECM has two plugs one on the right is the main wiring loom the smaller plug on the left may be where the wiring goes. On thing for certain the wires for the MAF run into one of the wire looms and associated plugs on the ECM.
G6mdxvct is offline  
Reply

Tags
3.2 , maf , mass air flow , touareg , wiring

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Club Touareg Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome
 

VW Touareg News Delivered to your Email!

Stay up-to-date with Touareg news in your inbox.

unsusbcribe at anytime with one click

Close [X]