Check engine light on, intermittently - Club Touareg Forums
 
Thread Tools Display Modes
post #1 of 8 Old 11-08-2011 Thread Starter
Junior Member
 
Touareg: 2012 V6 TDI
Join Date: Dec 2008
Location: US - Rochester, NY
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Check engine light on, intermittently

I have a 2004 V6 and the check engine light has been on for a day then off for a day. Its not blinking and according to the owner's manual its likely an O2 sensor. We did the gas cap check (still had the light on) and had the dealer check out the O2 sensor and it was fine. Supposedly the vacuum hose was loose but they fixed that and the check engine light did not come back on....until about an hour after we left the dealer. (they had the car two days and did about 50 mile road test - the light did not come back on).

Any suggestions on what could be causing the check engine light to come on for short periods of time then turn off?
zakthedog is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 11-08-2011
Touareg Guru
 
noobytoogy's Avatar
 
Join Date: May 2009
Posts: 16,269
Thanks: 0
Thanked 276 Times in 211 Posts
Any problem starting it [the engine turns over more than normal but does start] after it has been driven and then left for about an hour?

Did the dealer run a VAGcom check for error codes?
noobytoogy is offline  
post #3 of 8 Old 11-08-2011 Thread Starter
Junior Member
 
Touareg: 2012 V6 TDI
Join Date: Dec 2008
Location: US - Rochester, NY
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
No problem starting and runs otherwise normal - no unusual noises, all gauges indicate normal operation.

The dealer did run a VAG com check everything was within speck. Unfortunately I don't know what the error code was.

Is there a way for me to check the code without bringing it into the dealer?
zakthedog is offline  
post #4 of 8 Old 11-08-2011
Touareg Guru
 
noobytoogy's Avatar
 
Join Date: May 2009
Posts: 16,269
Thanks: 0
Thanked 276 Times in 211 Posts
Only if you have access to VAGcom or similar fault reader.

When my light came on it turned out to be a duff coolant temperature sensor which caused the starter to turn the engine a few more times than normal when the car was partially warm.
noobytoogy is offline  
post #5 of 8 Old 11-08-2011 Thread Starter
Junior Member
 
Touareg: 2012 V6 TDI
Join Date: Dec 2008
Location: US - Rochester, NY
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for your reply! It starts with no trouble - cold or warm. I'm beginning to wonder if its a faulty sensor (O2 maybe?). We had a problem with the TPM a few years ago and one other sensor sending a false problem. Needless to say our faith in the sensing system is a bit shaken.
zakthedog is offline  
post #6 of 8 Old 11-08-2011
Touareg Enthusiast
 
Touareg: 2009 V8
Join Date: Feb 2010
Location: Miramar, FL
Second Vehicle: is not a VW
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by zakthedog View Post
Thanks for your reply! It starts with no trouble - cold or warm. I'm beginning to wonder if its a faulty sensor (O2 maybe?). We had a problem with the TPM a few years ago and one other sensor sending a false problem. Needless to say our faith in the sensing system is a bit shaken.
Bring it to a local Pepboys (one by Keeler) or Advanced Auto Parts (on Clinton). They have a generic OBD II scanner that can read faults. I think you can even request for a print-out. Then you can go online to search/research the code.

There is an ECU Flash/update from VW for our model trucks that decreases the OČ sensitivity. It is an sissue with V6s...Ask the dealership.

Good Luck.
rarod58 is offline  
post #7 of 8 Old 11-09-2011 Thread Starter
Junior Member
 
Touareg: 2012 V6 TDI
Join Date: Dec 2008
Location: US - Rochester, NY
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks rarod58! I'll give that a try.
zakthedog is offline  
post #8 of 8 Old 11-09-2011
Touareg Enthusiast
 
Livefreeandrive's Avatar
 
Touareg: 2004 V8
Join Date: Oct 2009
Location: New England NH-CT
Second Vehicle: Other
Posts: 174
Thanks: 0
Thanked 0 Times in 0 Posts
Low coolant...

2004 Touareg V8 Shadow Blue 120k miles. Navigation, Tow Package, Air
Livefreeandrive is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Club Touareg Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
V8-04' Fuel cap Light > Check engine light Tahoe General Maintenance & Repair 8 07-21-2011 06:23 AM
check engine light on... georgewhr General Maintenance & Repair 4 06-01-2011 06:01 PM
fan running when engine off and check engine light on prosh General Maintenance & Repair 9 01-30-2010 02:53 PM
Check Engine Light Kirk General Maintenance & Repair 4 03-27-2008 07:06 AM
Check Engine Light chrislaw92 General Maintenance & Repair 6 02-15-2008 12:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome
 

VW Touareg News Delivered to your Email!

Stay up-to-date with Touareg news in your inbox.

unsusbcribe at anytime with one click

Close [X]